SB580 & SB680 – Not working with Windows 10

A school I support was recently upgraded to Windows 10 across site, and with this we also upgraded their version of Notebook 11.4 to the latest version (Notebook 16).

90% of the computers all worked fine, but a couple would not communicate correctly with the SMART Boards – they were both older SMART Board models, the SB580 and SB680.

According to what I’d read online, SMART have dropped support for these models (amongst other older models), purely down to the amount of issues they were getting logged by users on newer operating systems. Now I know you can’t believe everything you read online, but this sounds like something they would do.

 

The problem is when you plug in the board to a Windows 10 PC, it doesn’t always seem to pickup the correct drivers, meaning touch works (sometimes) but when you pick up a pen and draw nothing happens.

 

The fix is quite simple really, all you need to do is go to Computer Management > Device Manager and right click on the SMART Board Device Cable (The actual name will differ depending on your board, but it should be obvious which one you need to change) and choose update driver.

Then choose “Browse my computer for driver software”, and depending on your version of SMART Notebook / Product Drivers you’ll need to browse to one of the following locations:

C:\Program Files\SMART Technologies\Education Software\Drivers

or

C:\Program Files\SMART Technologies\SMART Product Drivers

Click OK, and the drivers should be found and installed automatically – your board should then work as you’d expect (be aware that depending on your version of Windows, the install location may be “Program Files (x86)”).

 

Hopefully this will save you some time like I wasted, installing and uninstalling different versions of Product Drivers whilst slowly losing my mind.

 

Thanks to BHMS at Edugeek for sharing this fix, and getting my users back up and running! I’m merely passing on the knowledge.

17 Comments


  1. Good post! I read your blog often and you always post excellent content. I posted this article on Facebook and my followers like it. Thanks for writing this!

    Reply

  2. I was losing my sh*t with the old smartboard and wasted so much time on trying to fix it through old drivers… Thanks for this fix!

    Reply

    1. No problem, glad I could help!

      Reply

  3. This installed, but it keeps disconnecting and reconnecting…won’t stop. Any ideas?

    Reply

    1. The only time I’ve had this issue has been either an issue with the serial to USB cable coming from the SMART Board, or an issue with the USB ports on the laptop.

      Not saying that’s the case for you, but definitely worth a shot testing it with another laptop or serial to USB cable if you have the resources to do this and haven’t already tried.

      Let me know how it works out for you.

      Reply

  4. I have used this trick the last few years, but now I have multiple folders to select from when I choose Drivers folder….LowRider,nw1900,SDC280,SDC330,SDC450,Voltron,x64 and x86. Any of these what I should choose?

    Reply

    1. You should just be able to choose the root driver folder (ensuring “include subfolders” is checked) and it’ll find the drivers for you.

      Reply

      1. There is no “root driver” folder, or at least I am not sure what that would say.

        Reply

        1. Sorry, I didn’t mean a folder named “root drivers”, however the root of the drivers folder.
          When you choose “drivers” and have multiple folders listed below. You should be able to select the “drivers” folder to install from.

          Ensure you check the box named “include subfoldes” and it’ll search all the folders you mentioned within the “drivers” folder and automatically select the best driver for the hardware.

          Hope that helps and clarifies my previous comment!

          Reply

  5. Your post lists the exact problem I’m working through with my SB680s. However, I haven’t yet had success. In Device Manager, would I be updating the SMART HID Device listed under Human Interface Devices? Or is there a different (or more) devices that also need drivers?

    Reply

    1. Hi Stephen,

      The exact name of the hardware changes depending on the age and model of the board, however that sounds about right for the 680s.

      In my experience, there’ll be no harm caused if not, it just simply won’t install the drivers and you’ll be free to try the next Smart device in the list.

      Reply

  6. Hey!
    I can’t find any of the drivers, any ideas?

    Reply

    1. Sorry for my late reply, your post got lost among a flurry of spam comments.

      By any chance are you trying to do this on a PC that has been built by WDS/MDT or something such as this? If it’s ever been sysprep’d it’s common for the drivers to be stripped out, in which case a reinstall of SMART then following these steps usually helps.

      Reply

      1. Hi I have a smartboard sb580 which my grandma had gifted me. I am a student nurse and would love to use this with my course. however it says version not supported. i have installed drivers… and when i go on the smartboard website it says device no longer supported.

        Im not sure how to sort it. i have done all the above suggestions but the interactive side of things are not working. i have tried orienteering…. and when I go to device manager it says device working correctly.

        please help, thank you.

        Reply

        1. What colour light shows on the bottom right of the board when it’s plugged in?

          Is it constant or does it flash.

          It is correct however that the boards are no longer supported by SMART. This support was dropped when W10 was released due to incompatibility problems, however my above workaround has always fixed it for me.

          Reply

  7. Hi it’s a constant green colour, I have tried the above instructions but still states incompatible software.

    Thanks
    Aliya

    Reply

    1. Do you have all the pens and rubber on the pen tray too?

      What version of SMART Notebook are you using?

      Reply

Leave a Reply